Problemi alla connessione WiFi su portatili Dell

Scritto da Marco il 10 febbraio 2009

Categorie: hardware

Ci sono diversi portatili Dell in giro, equipaggiati con tecnologia Centrino, che incorpora la radio WiFi Intel 3945BG. Neanche a dirlo, il mio Latitude D630 entra a pieno titolo nel gruppo.

Mi sono imbattuto in questo problema in modo assolutamente illogico (ed è questo che mi ha davvero infastidito), perché si è presentato improvvisamente ed in modo imprevisto. Il fatto di non essere ancora riuscito a capire la causa scatenante mi rende quasi idrofobo, ma per fortuna di questi tempi ho molto da fare e quindi il cursore dell’incazzatura è puntato altrove.

[SCENARIO]: Circa un mese e mezzo fa ho cominciato a notare degli strani problemi di connettività, per cui il mio notebook, se lasciato in idle per più di una decina di minuti — tempo di una telefonata importante di lavoro, quindi — al risveglio presentava la scheda wireless come operativa, ma di fatto inoperante, come spenta. Windows XP la vede funzionante, il driver è ok, ma la scheda non risponde. Nessuna comunicazione di rete. La macchina non va più in stand-by perché non comunica con la sk di rete, lo spegnimento è possibile solo con shutdown /s /f /t 0.

Note tecniche per smanettoni:

  • Sistema operativo Windows XP SP3, aggiornato e patchato, driver e software del produttore tutti all’ultima verione disponibile (pure il BIOS!);
  • la gestione energia della scheda è disabilitata, perché non sopporto che win mi butti giù la connessione di continuo quando ho ancora mezz’ora di batterie, e mi tocchi richiedere un lease DHCP ad ogni clic su Google Reader;
  • nessun problema con il power management, dato che è tutto always on quando il notebook è collegato alla AC;
  • il riavvio a caldo dei servizi di rete non è praticabile, perché la scheda non risponde e la richiesta resta in pending;
  • questo è il punto più fastidioso: essendo il PC con cui lavoro e porto tutti i soldi a casa, non ha su troiaini di alcun tipo, tutto il software che c’è sopra (da Firefox a Office a VMWare) è stato installato nei primi due giorni di vita di questo attrezzo, quindi più di un anno fa, e da allora gli unici software che possono essere passati per questo sistema sono gli aggiornamenti. In particolare non ho mai aggiornato il vmware 6, che tra tutti potrebbe essere l’unico che parla da vicino col driver di rete.

[TROUBLESHOOTING]: Controllo tutte le impostazioni varie, ma non ci sono modifiche rispetto alla Mia Configurazione Standard (ogni topo da sala server ha la propria), il che  — come già detto — mi manda letteralmente in bestia.

Controllo sul sito di Dell se ci sono articoli a riguardo, ed eventuali aggiornamenti software. Niente.

Responso di San Google: problema noto. :-) E ti pareva. Tra i soliti n-mila risultati, i più significativi mi sembrano questi:

http://social.technet.microsoft.com/Forums/en-US/itprovistahardware/thread/f525a7a3-47af-4476-9f99-99e1f1736a09/

http://www.mydigitallife.info/2007/09/15/intel-pro-wireless-3945abg-wifi-radio-adapter-shut-off-randomly/

Peccato che: il primo è datato e parla di driver immaturi e quindi poco ha a che fare con il mio caso, dato che ho su un S.O. stabile con driver ultra-collaudati; il secondo, pur descrivendo precisamente la fattispecie, pontifica che “the problem does not happen under Windows XP system”. Le balle di Pio IX. Ed io che ho davanti?

Inutile sperare nell’event viewer. Nessuna traccia.

Inizio la procedura standard di ricovero. Aggiorno il driver della sk di rete con quello del produttore che si trova QUI, sostituendo i 70espiccioli MB del sw Dell con il solo driver Intel (7.1 MB, for the records …). Niente. Tutto come prima.

[SOLUZIONE]: Disinstallare il Dell Quick Set, che in pratica è quello che controlla tutti i bottoncini vari, integrando la GUI del power management e della luminosità adattiva del monitor. Il problema è sparito del tutto (per ora), anche se ancora non si spiega perché si sia presentato improvvisamente dopo un anno. Il che dovrebbe suggerire di cercare la soluzione altrove, chissà che non ci scappi qualche puntata successiva.

Dato che tutte le funzioni corrispondenti possono essere impostate dal BIOS, l’unica mancanza pratica consiste nel non avere i messaggi a schermo quando si cambiano le relative impostazioni. Sai che rinuncia.

Di fatto mi chiedo come sia possibile che un tale crapware sia rimasto sul mio PC principale quando ho fatto la classica pulizia in uscita dalla scatola, che ormai con i notebook attuali somiglia più alla purga del ’37 che ad una routinaria disinstallazione di software poco utile.

Shame on me, per una volta. Pasticcio con la macchine di Von Neumann da troppi anni per commettere impunemente un errore di questo genere.  Spero che quest’esperienza serva a qualcun altro.

Scrivi un commento. Fai sapere che ne pensi!